Re: Updated everything, a few problems within....

Updated everything, a few problems within.... (January 18, 2018 09:44PM) pnutsnz
Hi all,

Well, at present I am trying out a MacPro tower (2010) 4,1 flashed to 5,1. Not really gone too smooth, but have a nightmare with FCPX.4.

When I was looking at the machine, I was offered a SSD drive. Thought yep, pay the extra, future proof things. One question I have here is why are the SSD's so small in capacity?. this is only 120GB. I have preferences files bigger than that!.
Anyway, got that. Then I was asked if I wanted to update the MACHINE RAM to 16GB (from 8gb). Thought gee, lets go for the 24GB's that were on offer, again going for the long term investment.
The machine was setup with High Sierra, so that is good.

Only version of FCPX I could go for was 10.4, so update to that. But here is where the problems start. It is certainly a lot faster to start than the old setup. That s good. But just at odd times it crashes. One time I was changing the window size for the screen. I got it adjusted to the first move, then when I went to fine tune that move - CRASH. Instant finder. another time I was previewing a filter by doing a rollover, got halfway through the filter, then crash.
Other times are just random. Except there is one thing I cannot do without it crashing every time, and that is try to access the Preferences in FCP. Not going to happen. Back to the finder as well.

Any ideas as to a fix?. Does sound like corruption, but on a fresh install?. Not looking too stable :).

I like the Mac Pro tower - it will give me plenty of expansion with Audio / Video cards. But things have not gone smoothly - that is for sure.

Thanks everyone.

Re: Updated everything, a few problems within.... (January 19, 2018 04:20AM) philsfilm
I'm running a 27" iMac (mid-2011) with 20 GB RAM. Since upgrading to FCP 10.4, I've been getting frequent random crashes when I do simple things like turn on and off color effects like Color Wheels or Color Curves. You should report this to Final Cut Pro Feedback. You probably won't get a reply but the tech support do read the comments and may include a fix for what I suspect isa bug (at least in my case).

Re: Updated everything, a few problems within.... (January 21, 2018 05:13PM) pnutsnz
Thanks Phil - will send to Apple.

Actually at present I have been working on the Mac Pro. Hasn't gone smoothly - but am seeing the light at the end of the tunnel.

Just have one dilemma.... The main start drive is an SSD. Since it is only 120gb in size, I have managed to fill it up with just a few of the programs I use. This has created a problem with FCPX, as I cannot install the 'Templates Folder' - which of course holds all the plugins. At present I cannot see a way around this, as if the templates are not on the same drive as the start volume, FCPX just creates a new one with the basics. I did try to install the templates on a spare drive I have mounted, then zipped across an ALIAS of that folder to the Movies location. It does not get recognised.

Any ideas?


Re: Updated everything, a few problems within.... (January 22, 2018 02:05AM) VidGreg
Hi Pete
My best advice to you would be to purchase a larger ssd for your boot drive. It really is important and there is no work around if your drives don't have a good amount of free space. You will see significant slowdowns, spinning beach balls and even experience possible crashes if you don't maintain at least 10-15% empty space on your drives. They will start slowing down even with 25-35% free space. Video tends to be large continuous files, and you are just making the drives work too hard and ssd drives write in large blocks. Large files and large blocks need space.
So really, you need to save your pennies and get a larger drive.
While I haven't attempted to move the templets folder to a different drive, I suspect that in order for this to work, you need to create Symlinks not alias'. Symlinks are necessary when an application calls for resources during the launch routine and an alias does not get accessed until after launch completion. In Logic ProX as an example, you have to use symlinks not alias' for the sound libraries, otherwise LPX will just attempt to download them during launching the program. A symlink is a lower level file address that points to location. You need to use Terminal to create symlinks.
Like I said, I haven't done this for the plug-ins, but I keep sound libraries on an SD card and use symlinks to point to them. The SD card is fast enough and I need all my other ports for audio interfaces and drives on my rMBP.
Hope this Helps, Greg
Re: Updated everything, a few problems within.... (January 22, 2018 06:01PM) pnutsnz
Thanks so much Greg for the detailed reply.
Well, I had a go at creating Symlinks, both using a utility (Symbolic Linker) and with terminal - looks like both failed.
Maybe it cannot done with the Templates Folder?.

Any body else done this?.

Checked up on (what I would class as a ludicrously small drive) a 1TB SSD drive. They start about $800.00. Ouch. That is not going to happen too soon.

I wonder why SSD's are so expensive?. The technology has been around for a while (flash drives), and they should be making this stuff by the millions in Malaysia - Indonesia - South China. Where everything else is made :).

Guess if a solution cannot be found, I will have to change the SSD to one of my 2TB sata drives for the start volume. It worked on the iMac - kinda well!.

Cheers for now,

Re: Updated everything, a few problems within.... (January 24, 2018 03:44AM) VidGreg
Hey Pete
Not sure where you are located, by ssd drives are not nearly that expensive. Amazon US sell 1TB drives starting around $240.00 for the Crucial MX500. You can get a refurbished Samsung 850 Pro from Best Buy right now for $200.00USD. The 850 Pro and EVOs are good drives, but Samsung just came out with the 860 model so I suspect that the 850s will see some discounting.
There are 500GB drives available for around $140.00USD on Amazon. All bets are off if you are in countries with high VATs but still believe $800 way too high. Saw 2TB drives for ~$500.00USD Crucial MX500/Amazon
If you keep all your media on different drives, you can get away with 500GB, or even 250GB.

Do you need ssd for media? Really depends on the type of projects you are working on. If 4K and up footage especially Multicam projects, then you definitely want one. 1080P can easily be run from hdds. Nice thing about the MPs is it is easy to stick in addition drives.
While this info is getting a little old, Larry Jordan wrote a pretty good article about the bandwidth needed for various formats here… []

Sorry can't tell you why your Symlinks are not working, should, if done properly. IFAIK, Symbolic Linker no longer works with latest OS's. Not supported in quite awhile. There was an updated version on Github(?) but I never use it, just Terminal. Not sure how the new APFS file system would affect it. If you are running High Sierra, then most likely your boot ssd is formatted with APFS not the older HFS+ (macOS Journaled). APFS and High Sierra requires a firmware update for the EFI boot ROM. It is included with the HS Installer, but has been giving folks issues. Doubt this applies to you, as when it fails, you most likely get a partially bricked computer. Since you are using a slightly hacked MacPro(4.1-5.1), it might be an issue, but don't think so. What GPU(s) do you have?

How are you trashing your Preferences? If you hold down the Option and Command key while launching FCPX you will get a dialogue box to trash preferences, click OK and FCPX will remove them prior to launching. Does your computer still crash? I would throughly check all of your plug-ins as they can cause crashes if not updated. Try launching FCPX on a clean user account without any plug-ins and see if this works.
Again, you do need space on the boot drive, so still think this may be your issue.

Best of Luck, Happy Editing
p.s. BareFeats has many articles/comparisons of performance of various Macs and use a 2010MP in lots of its comparisons.
Link here… []
Legacy MPs still great computers.
Re: Updated everything, a few problems within.... (January 25, 2018 09:47PM) pnutsnz
Gee, again thanks Greg for the helpful reply.
Yes, the big SSD's are quite expensive here. But having another look I have found cheaper alternatives with the 500GB size.
Not too sure why Sumbolic Links not working. It creates the 'shortcut' folder, I move that to the Movies folder okay. When I launch FCPX - it creates a new 'templates' folder with just the default goodies right next to the Symbolic linked folder. Like it does not recognise it at all. So maybe the Linker is not working?.
Might try using the terminal direct and see what happens.
I have back dated to FCPx.3.3 - which seems to be working fine. So am not using 10.4 at this stage.

I have attached a screen shot of the graphics data - hope that helps...

Again, thanks Greg. I shall try a few options, but looks like the symbol link is not working using the linker. So that might be a starting place there.


Re: Updated everything, a few problems within.... (January 26, 2018 09:51AM) pnutsnz
Well, making progress!.
I tried the Symlink using just terminal, and it all works - 100%. So I guess that SYMAPP did not work after all.

So all good as far as that is concerned. Thanks Greg again for the advice.

One thing I am confused regarding the PCI slots is that the machine is touted as having all slots PCIe. But 2 are 16 lanes, and 2 are 4 lanes. So do I have to match up whatever Graphics cards I buy with the correct amount of lanes?. Or do the correct amount of lanes get addressed by whatever card is present?.

Else all is going good.

All the best everyone,

Re: Updated everything, a few problems within.... (January 26, 2018 01:06PM) VidGreg
Hi Pete
Glad to hear you worked out Symlinks. I am in the middle of a fresh install for High Sierra and in process of re-downloading all my Pro Apps and so Logic/Garageband sound files are going back on a SD card using Symlinks. Saves over 50GB from my internal drive. FCPX 10.4 installed.

Put your graphics card(s) in the 16 lane slot(s). You want the most lanes for the GPU.
If you have a second matched GPU you can use 2 cards together for dual GPUs, but they need to be matching GPU cards.

Drives, USB3 PCIe cards, etc… can use any slot; even the slower slots with no issues. Even with just 4 lanes the PCIe bus has higher bandwidth than most drives. Your model has PCIe 2.0 buses.

Hope this Helps, Greg
Re: Updated everything, a few problems within.... (April 14, 2018 10:52AM) pnutsnz
Thanks so much Greg - sorry I have not been back to reply.
Yep, the Symlinks are a welcome feature. And are working fine.

Graphics cards are using the 16 lane bus. Thanks. I was familiar with matching the video cards, and have seen a few demos on youTUBE regarding This. Might be Worth a try out later.

thanks for the info Greg.

Cheers for now,

Sorry, only registered users may post in this forum.

Click here to login